帖子

21001 错误

 关闭 [复制链接]

该用户从未签到

22808  楼主| 1399708798muniu 发表于 2015-4-29 16:51:13 1#
我只是从原来好了的4.2 系统代码 换到 现在 4.4系统的项目  就一直报这个错

1、有没有使用SpeechUtility.createUtility()设置appid
2、有没有将libmsc.so放到工程中
3、如果使用的是讯飞语音+的本地功能,有没有安装讯飞语音+
4、如果设备是android 5.0及其以上,需要将工程中的armeabi和armeabi-v7a文件夹中都放上libmsc.so,如果你下载的SDK中没有armeabi-v7a对应的库,可以将armeabi中的libmsc.so复制一份到armeabi-v7a文件夹中
5、SpeechUtility.createUtility()如在Application中调用,需要在Mainifest中注册该Applicaiton。此方法不是必须在Appcation中调用,可在需要使用语音能力之前,例如进入语音搜索页面调用。


这个 看过了 也没解决

 楼主| 1399708798muniu 发表于 2015-4-29 16:51:35
2#
原来的 项目 现在 还可以用
使用道具 举报 回复
小西哥 发表于 2015-4-29 17:06:48
3#
Demo试了么,是否可以正常跑?
使用道具 举报 回复
hygui 发表于 2015-4-29 17:11:29
4#
麻烦提供一下您的工程源代码及日志
使用道具 举报 回复
 楼主| 1399708798muniu 发表于 2015-4-30 11:46:42
5#
hygui 发表于 2015-4-29 17:11
麻烦提供一下您的工程源代码及日志

我现在用的 就是你们的 DOME了 ,也不行,  不过 我是在android源码编译的   既然能跑起来 应该包是引用进去了的吧,
使用道具 举报 回复
 楼主| 1399708798muniu 发表于 2015-4-30 14:19:28
6#
你们的库文件 是不是 绑定什么 mac地址 什么的 只能在一台上面调试 ,   奇怪  一样的源码 只能在那一台机器上面调试
使用道具 举报 回复
fenghua__1314 发表于 2015-5-4 09:59:55
7#
1399708798muniu 发表于 2015-4-30 14:19
你们的库文件 是不是 绑定什么 mac地址 什么的 只能在一台上面调试 ,   奇怪  一样的源码 只能在那一台机 ...

问下在使用是什么服务的出现的?不能使用是否有相应的错误码?
使用道具 举报 回复
hygui 发表于 2015-5-4 10:09:25
8#
fenghua__1314 发表于 2015-5-4 09:59
问下在使用是什么服务的出现的?不能使用是否有相应的错误码?

错误码21001
使用道具 举报 回复
fenghua__1314 发表于 2015-5-5 11:07:02
9#
在使用系统源码编译的android.mk在将语音服务的libmsc.so和Msc.jar打入apk时,请注意不要将Msc.jar进行混淆,具体设置请参考:http://blog.csdn.net/silence_cdsn/article/details/41542877; 否则在运行时会提示: NoSuchMethodError
使用道具 举报 回复