帖子

[demo分享] 小白分享---Android Studio安装&使用问题集

[复制链接]
  • TA的每日心情
    开心
    2019-1-25 10:57
  • 签到天数: 245 天

    [LV.8]以坛为家I

    51908  楼主| Green&Hope 发表于 2017-9-22 09:09:55 1#
    本帖最后由 Green&Hope 于 2017-9-22 09:13 编辑

    AndroidStudio安装&使用问题集 (见附件,正文贴图太麻烦)                                       
    1.  错误: 程序包android.support.v4.app不存在
    其实是导入的工程不对,如下图(参考附件),需导入build.gradle 就可以解决。
    如还不行请参考:
    解决方法:
    1)File->rojectStructure->app->Dependences->Add Library Dependency
    添加后进行Gradle Sync 问题解决
    2)第二种方法:
    直接在工程目录下 Gradle Scripts-> build .gradle(Module: app) 下添加
    dependencies {
        compile'com.android.support:support-v4:24.1.1'
    }
    上述两种方式效果是一样的,只是操作方式不同
    2.报错(参考附件)
    需在build.gradle中添加代码
    buildscript {
       repositories {
           jcenter()
        }
       dependencies {
           classpath 'com.android.tools.build:gradle:2.3.3'

           // NOTE: Do not place your application dependencies here; they belong
           // in the individual module build.gradle files
        }
    }
    3.错误如下(参考附件)
    手机未及时按安装app导致,重新runOK
    4. 相应的Android SDK未下载,也会导致报错,设置下载如下:(参考附件)

    Android Studio安装&使用问题集.pdf

    489.64 KB, 下载次数: 440

    评分

    参与人数 1语点 +10 收起 理由
    百花 + 10 很给力!

    查看全部评分

    whypan 发表于 2017-9-22 15:00:00
    2#
    使用道具 举报 回复
    40089599@qq.com 发表于 2017-10-19 08:14:24
    3#
    good nice

    使用道具 举报 回复
    笑颜 发表于 2017-12-15 19:03:42
    4#
    图文并茂,谢谢楼主
    使用道具 举报 回复
    shujianghua@fox 发表于 2017-12-28 17:12:15
    5#
    学习了                                       
    使用道具 举报 回复
    shujianghua@fox 发表于 2017-12-29 13:47:35
    6#
    学习了                                                                     
    使用道具 举报 回复
    wutao168-88888@ 发表于 2018-1-29 10:02:09
    7#
    感谢分享,收藏了

    使用道具 举报 回复
    318547756@qq.co 发表于 2018-6-30 17:20:22
    8#
            Error running mscV5PlusDemo:
    This version of Android Studio is     incompatible with the Gradle Plugin used. Try disabling Instant Run (or     updating either the IDE or the Gradle plugin to the latest version)
    请问该如何处理?     

    楼内回复

    This version of Android Studio is incompatible with the Gradle Plugin used. Try disabling Instant Run (or updating either the IDE or the Gradle plugin to the latest version)----------不兼容,  详情 发表于 2018-7-2 09:28
    使用道具 举报 回复
     楼主| Green&Hope 发表于 2018-7-2 09:28:59
    9#
    318547756@qq.co 发表于 2018-6-30 17:20
    Error running mscV5PlusDemo:
    This version of Android Studio is     incompatible with the Gra ...

    This version of Android Studio is     incompatible with the Gradle Plugin used. Try disabling Instant Run (or     updating either the IDE or the Gradle plugin to the latest version)----------不兼容,升级either the IDE or the Gradle plugin 到最新版本
    使用道具 举报 回复