帖子

讯飞AIUI_PB_SDK中的protobuf版本与我App中的webRTC版本冲突

[复制链接]

该用户从未签到

9582 627464752@qq.co 发表于 2018-5-21 10:58:51 1#
本帖最后由 627464752@qq.com 于 2018-5-25 09:49 编辑

[libprotobuf FATAL ../../chromium/src/third_party/protobuf/src/google/protobuf/stubs/common.cc:67] This program requires version 3.3.0 of the Protocol Buffer runtime library, but the installed version is 3.0.0.  Please update your library.  If you compiled the program yourself, make sure that your headers are from the same version of Protocol Buffers as your link-time library.  (Version verification failed in "/Users/admin/work/veryfy/AIUI_PB_SDK/AIUI_Src_PBTP/src/libaiui/base/protocol/pbtp/AIUIPBTP.pb.cc".)
我现在需要protobuf 3.0.0版本的AIUI_sdk。帮帮我。谢谢。

Jack明明361 发表于 2018-5-21 14:11:45
2#
这个问题的本质是protobuf库冲突,AIUI SDK中使用的protobuf版本是3.3.0.有两种解决办法:1.混淆webrtc中的protobuf库,避免冲突。

2.AIUI SDK混淆protobuf库。AIUI混淆protobuf库预计要6月初-6月中旬混淆后上线。
建议先尝试第一种方案解决。

楼内回复

请问你是讯飞技术人员吗。6月份的新版本SDK会解决这个问题是吗?  详情 发表于 2018-5-21 16:35
使用道具 举报 回复
 楼主| 627464752@qq.co 发表于 2018-5-21 16:35:01
3#
Jack明明361 发表于 2018-5-21 14:11
这个问题的本质是protobuf库冲突,AIUI SDK中使用的protobuf版本是3.3.0.有两种解决办法:1.混淆webrtc中的 ...

请问你是讯飞技术人员吗。6月份的新版本SDK会解决这个问题是吗?
使用道具 举报 回复