帖子

TTS WebApi一直提示参数错误

[复制链接]

该用户从未签到

5582  楼主| cheetah 发表于 2019-10-23 16:03:16 1#
语言是C#,请求参数如下:
  1. {
  2.     "common": {
  3.         "app_id": "5c56f257",
  4.         "uid": ""
  5.     },
  6.     "business": {
  7.         "ent": "intp65",
  8.         "aue": "raw",
  9.         "auf": "audio/L16;rate=16000",
  10.         "vcn": "xiaoyan",
  11.         "speed": 50,
  12.         "volume": 50,
  13.         "pitch": 50,
  14.         "bgs": 0,
  15.         "tte": "UTF8",
  16.         "reg": "2",
  17.         "ram": "0",
  18.         "rdn": "0"
  19.     },
  20.     "data": {
  21.         "text": "5Lik5Y+q6buE6bmC6bij57+g5p+z77yM5LiA6KGM55m96bmt5LiK6Z2S5aSp",
  22.         "encoding": "",
  23.         "status": 2
  24.     }
  25. }
复制代码

参数和官方文档对比了,没法发现参数错误,但是返回的结果一直提示参数错误。
  1. {"code":10163,"message":"param validate error:/business invalid param:'tte',/data invalid param:'text',","sid":"iat00072639@gz16df79e96ad507d802"}
复制代码

而且基本上每次提示的错误参数都不相同。
2019.10.23 16:00:23
  1. {"code":10163,"message":"param validate error:/business invalid param:'tte',/data invalid param:'text',","sid":"iat00075621@gz16df7a2a48b507d802"}
复制代码
2019.10.23 16:02:15
  1. {"code":10163,"message":"param validate error:/business invalid param:'pitch',/data invalid param:'text',","sid":"iat00077f43@gz16df7a2efe35075802"}
复制代码
2019.10.23 16:02:50
  1. {"code":10163,"message":"param validate error:/business invalid param:'auf',/data invalid param:'text',","sid":"iat00079833@gz16df7a381e1507d802"}
复制代码





讯飞2017hj 发表于 2019-10-23 17:10:12
2#
建议url地址或者信息是否用错,使用的tts的能力返回的sid显示请求的好像是听写。

楼内回复

非常感谢,确实我是的URL填写错了。  详情 发表于 2019-10-23 17:29
使用道具 举报 回复
 楼主| cheetah 发表于 2019-10-23 17:29:36
3#
讯飞2017hj 发表于 2019-10-23 17:10
建议url地址或者信息是否用错,使用的tts的能力返回的sid显示请求的好像是听写。
...

非常感谢,确实我是的URL填写错了。
使用道具 举报 回复